Raspberry Pi 試用 – NASを作ってみる 2 [完成]

前回、『ここまでできりゃもう安心』なんてのたまっておるが、そんなこと言うから簡単扱いしていた”HDD繋いでRAID構築して”でコケた。
作業時間は長くないものの資材調達に日数を要して結局始動は19日。

前回はHDD繋ぐ手段がなくて一旦中断としたわけだが、翌日早速4baysのHDD箱を手配。momoでコレを発注だ。多分MediasonicのHF7-SU31Cだ。
momoは24時間着荷はないので11日に到着。

せっかく再構築なので余剰の1TB HDD計2個 + RAID0で使用中の1TB HDD2個を使ってRAID5とかやってみたいと思っておるが、まずは余剰の2個でBayを入れ替えて動作確認。4スロットとも個別に認識されてまずはOK。
続いてOpenMediaVaultのRAID機能でRAID1を試してみようとしたのだが、

なんてことを。
Raspberry PiにはSATAとかついてないのでこれではRAID組めねーでないの。
まぁそこはそれRaspberry Pi用のRAID拡張基板とか売られてはいるんだが、送料考えると高いし売り切れだし。
そこで、OpenMediaVaultの機能ではなくOSでRAIDを組んでからOpenMediaVaultに認識させてやったらどうぢゃろ、ってことで、mdadmでRAID0を組んでみた。

ちょっと引っかかったのはコレ。

OpenMediaVaultインストール後、パスワード不明でSSHでrootログインできない。
なのでroot権を与えたユーザでログインしたが残念、mdadmを使うにはSuperUserじゃなきゃあかん、と。
そんでやむなく頭にsudoを付け、”sudo mdadm …”としたらできたのでまぁとりあえず解決。

企み自体はうまくいって見事RAIDデバイスがOpenMediaVaultに認識されたんだが、初期構築に80分かかってがっかり。こりゃあかんわ。
遅いという話も身近に聞いているし、実際USB接続HDDのRAIDは不安定という検索結果も多いし、ここはこのHDD箱を諦めQNAPのRAID箱に交換することにした。

だが、momoは別商品への交換に応じてくれず、仕方なく返品処理。
返品ならQNAP製品の買い直しは別にmomoじゃなくても、ってことでPCHomのほうがNTD200ほど安かったのでQNAP TR-004をPCHomeで手配、翌日12日着荷。

TR-004は単体でハードウェアRAIDを組んだ状態でPC等接続機器に認識されるのでOpenMediaVaultでの手間はない。実際同じくRaspberry Pi 4のでOpenMediaVaultでTR-002で組んだ先達が友人なのでそこは確実。
で、その安心感から稼働済みNASは停止、RAIDではないバックアップHDDを更にバックアップし、バックアップHDDだったものをOpenMediaVaultに認識させてひとまずRAIDなしのNASで動かしてみた。アクセス権もなんの問題もなく稼働し、今までのBuffaloのNASより早い。素晴らしいやん。

さて本番のTR-004でのNASですよ。
ちょっとすぐには手が出せず15日に開梱して使ってみるが、残念無念HDD4のLEDが点灯しない。但し他の動作は正常。
新品導入からいきなり不具合があるのは嫌だし、HDD4に問題が起こったときにランプなしってのも嫌なのでここはサクッと返品交換。
・・・なのだが、にゃんとPCHomeの24h到貨では交換を扱っておらず、返品及び買い直しとなる、と。うわメンドイ。
まーこんなこと交渉して時間かかるのも更にメンドイので、返品処理して再発注した。
再発注品はもちろん翌日に届いたのだがここで18日。日数かかっちょるなぁ。

ここまでにRAIDなしでPi NASは使っていたので、TR-004さえ動きゃ問題なしだ。
今度こそ大丈夫だろう、と4Bays全てにHDD入れて起動すると、流石に今度はOK。
でも、未使用2台はフォーマットが必要なのだが、TR-004ではできずOSでやらにゃならんのだそうで。
旧NASから外した2台はExt3だが、どうせなら4つともExt4にしたいね、っちゅうことで
“デスクトップ機のLinuxで”Ext4にフォーマット、RAID5で全領域確保。

コレで大いなるハマりをすることになるのにねぇ・・・

これでOK、とOpenMediaVaultでアクセス設定をしていざ他OSで見てみると、にゃんと各ディレクトリは見えるがアクセスできないのでした。
LinuxとWindowsでは”アクセス権なし”、MacOSでは”実体がない”とされる。
まーなんだ、MacOSの”実体がない”は時折出るが信用できない文言なので無視、LinuxとWindowsがいうアクセス権の問題だろうと推測。
でも、設定のとこをどう見てもアクセス権はあるはずなんだよね。
最後にはOpenMediaVault上で重複している権限設定をすべて与えてかつ特権もついた状態でも”アクセス権なし”と。
結局深くいじりすぎて動作をおかしくしてしまったので、一旦ストレージディスクを消して仕切り直すことにした。

ここでだ、前回はLinuxでフォーマットしたわけだけど、そのせいでLinuxのユーザ権限がストレージ全体に及んでいるんじゃなかろうか、と思ったわけですよ。
そこで今回はOpenMediaVaultでフォーマットしてみた。

すると、難なくフツーの権限設定で正常にアクセスできるように。

あぁ、またバカバカしいことでハマってしまったわ・・・

ともあれ動きゃこっちのもんだ。
バックアップデータを差し戻し、無事正常稼働。RAIDなしHDD単体で動かしていたときより更に早くて非常に快適ですわ。

こんな具合に完成。
Raspberry PiはQNAPの箱内部の隙間に入れてみた。なので外見上は単体のNAS風味。
隣のD-Linkは、以前バックアップ用だったRAIDなしHDD。これは引き続きバックアップ用として使うことにする。

カテゴリー: ガジェット パーマリンク

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください